Out of hibernation

Positive temperatures have returned. The snow is melting and since I can step outside in a t-shirt (I am pretty cold tolerant), spring must be around the corner. Finally! Though, I shouldn’t say it too loud. While spring may come next week, according to the calendar, we are looking at another month and a half before it will stop freezing (crossing fingers). The past winter was the coldest and strongest we have experienced. Record cold temperatures – as cold as -50F or -45C is a new state record – and back to back snow storms really make you wish at times you were in a tropical place instead of the Maine foothills and mountains. One is almost a prisoner inside his/her house. Absent a january and february thaw, today is the first day I can start pulling up our outdoor Christmas decor, now that the last bit of snow & ice is melting. It looked great for about two weeks, until it was entirely burried under snow. A few people have asked how things are, since I haven’t blogged in way too long (mea culpa). Things are good. We can’t complain. 2008 was an odd year, and a busy one too. I don’t know how many trips we made and miles I drove, off the top of my head. Looking back it feels like I was somewhere else every few weeks and didn’t get anything done, so to speak. The year started out nice and quiet, spring came, we started gardening and prepared for some DIY projects. Then extra family responsibilities cropped up … and time flew. We ended up not doing much remodeling, besides a total redo of the TV room & closet under the stairs. I had planned  to work on the cabin, but we were just too busy and pre-occupied with work and family matters.  I did learn a thing our two about cars, trailers and boats though. There is a Jeep in the family now and I am the captain of our boat :) But, more on that in a short while.

Continue reading >>

Exporting from iBlog 1 and 2 to WordPress

Did you ever wish to export your entries from iBlog 2 to another platform? Absent completion of iBlog 2 and an official export tool / script from Lifli, you were pretty much on your own if you wanted to switch away from iBlog. With iBlog 1 there was a 3rd party tool, but the geeky adventure is not really for novice users or the faint of heart. If you are interested in this route, I recommend Bruce McKenzie’s  Step by step guide iBlog to WordPress. There is some change regarding versions & installing of MAMP & WordPress, but the guide outline still holds. With iBlog 2 you were looking at long nights of copy – pasting, depending on the size of your blog. That is, until now. I was contacted last week by fellow iBlog user Jerry Seeger from Muddled Ramblings and Half baked ideas. Facing the thought of manually exporting his entries, he grabbed the bull by the horns and developed an export script that allowed him to migrate his entries from iBlog 2 beta to WordPress. Story about this on his blog. He contacted me to ask if there are fellow iBloggers out there who would benefit from his script.; which I know there are some. In brief communication with him I suggested a tutorial and forum might be handy to more easily help other users and aid with communication & troubleshooting. So,  he created the iBlog Survivors forum. Regardless of whether you want to move to WordPress right now or later or wish to keep using iBlog; I think it would benefit all current users to register on the iBlog Survivors forum. With the loss of the ibloggers. net forum we lost a major line of communication and peer to peer assistance. I think that, using Jerry’s script, it should also be possible to easily migrate from iBlog 1 to WordPress. Get iBlog 2 beta. Import your v1 blog into v2. Then export using Jerry’s script.

Continue reading >>

Restoring image links from imported iBlog entries

I just restored the image links for the old entries that originally were posted with iBlog. After exporting the iBlog entries using Agitprop and importing them in a local WordPress install using MAMP (or WAMP) – Bruce Mc Kenzie has a very good write up on this process on his blog – the image links pointed to localhost. This meant they showed fine on the local computer. Upon importing the entries into a live WordPress blog, those links are not updated however and the images not imported. The typical result is no image is displayed and/or a blue question mark square in the entry: Two things are going on: 1) the images are not present in WordPress 2) the paths to the images inside the entries are incorrect There has to be an easier way to fix this outside of opening iBlog and a 3rd party offline WordPress client (can’t be done online, as images need to be uploaded) simultaneously; and copy/pasting entry data between the two. Each problem actually has an easy fix and can be done online or offline in your MAMP/WAMP environment. Step 1: Add iBlog images to the WordPress installation iBlog has the following folder structure. Images are buried several levels deep. Which would give you a serious workout if you were to manually retrieve those images. Using FileJuicer (MacUpdate, Homepage) you can extract all the images in one step. In the Preferences, select the images file types you wish to extract (generally GIF and JPG) and in the results designate a destination folder. Deselect thumbnails as those are not needed. Drag and drop your Sites > iBlog > Bxxxxxxxxx folder over to the FileJuicer window and it will do all the heavy lifting for you. In the result folder there will likely be some category icons and maybe some other files you know you will not need on the new blog. So delete those. Time to upload the rest of the extracted files to your WordPress blog. You may know that WordPress stores images in dated year and month folders, which would pose a problem. But, the old iBlog entries we imported have an image path without dates; so we can just simply upload all iBlog extracted images to one folder. To keep things neat and tidy I decided on a subfolder /iblog under uploads. Using FTP I created iblog under uploads. And copied all extracted images over. That concludes step 1. Step 2: Correct the image paths of imported iBlog entry images Manually this would be another one of those repetitive nightmare things. Fortunately we can use a super handy Search and Replace plugin. (WordPress extend directory, Plugin Developer Homepage) Download the plugin, copy it to the WordPress plugin directory on your server and activate it in your WordPress environment. Safety note: There is no undo with this plugin. So, make sure you have a backup of your WordPress installation and database and familiarize yourself with how you may have to restore it in…

Continue reading >>

DNS vacuum – no email for me?

Or maybe I should say DNS hell? If you have tried to email me in the past week, you will have received a 550 Relay Prohibited automated reply. Which is unfortunately not fixed yet. This 1and1 domain now points correctly to mediatemple (not .mac or wordpress.com), but it also ate my email settings. 1and1 Support said that shouldn’t have happened and has given me instructions on how to solve it. Basically you revert Basic DNS Settings back to 1and1 and then switch back to My Name Server, add mediatemple again as your own name server, save, wait for updating. You see the web domain go down … and back up. And, you still don’t get email. Wonderful. A second call. Followed the instructions on the phone. Wait. Still no email. To me it seems there is an issue with their setup where Basic and Advanced DNS don’t mix. With the Default Basic DNS you get access to the MX mail server. Strangely enough once you point to your own DNS server – as per their instructions on how to do it – the MX server disappears from Advanced DNS. I think their support suggestion of applying settings under both Basic DNS settings doesn’t work. To me it seems like a clear selection from a pull down menu for a reason. Which ever you have selected in Basic is what is retained when you hit Save. Time for call #3. I sometimes really cannot understand how something so simple can be so hard with large companies. I can’t be the only one, let alone the first one, having this problem. Can I? I’m also trying to get some input from MediaTemple (mt). I have recreated my mailbox there, but neither the old mailbox at 1and1 nor new one at (mt) is getting any mail. Hopefully things will be back to normal shortly. Nothing is more frustrating than trying to fix something you don’t have control over. Update: Fixed! Now, why didn’t any of the smart people at 1and1 tell me that after changing the DNS setting, the record is actually controlled by (mt)? Rooting around (mt) moments ago I just found I could edit my own zone file which contained my new MX server setting. And, (mt) just informed me I had created my email account correctly, but not activated it in another screen. Eh? All right. My bad then.

Continue reading >>

Swim! Swim! We’re live!

Chances are this is your first visit to my new online home. Welcome. After a little nudge from Bruce yesterday, and the release of wordpress 2.5, I decided to take the plunge and move the data over from wordpress.com and just go live here. Cold turkey. Dive in and swim. (or “Boom!” as SJ would say) I had the server space for a while already, looked a little bit closer at wordpress.org but kept waiting for either a) me to manually fix the old iBlog entries that didn’t carry over well into wordpress.com or b) the new export function from iBlog 2. I don’t really want to do the manual thing, the iBlog export function is not here yet and at the same time I want to get a little bit of a custom blog up again. The old stuff isn’t that important right now and I can fix it later when I have more time. So, here it is and here you are. New blog meet visitors. Visitors meet new blog. No, the new blog is not finished yet. I still need to bolt a few things onto the chassis. I already had to make some changes to my original theme idea. That’s how things go, you think something will look right and then you say … eh, no! And, since right now the blog is running on a modified third party theme; I am sure there are still some cobwebs around. In fact I have only edited a handful of the dozen or so files … so who knows what you see on some pages. But, it is a start and a new beginning. The landing page looks OK and the rest will come gradually. We’ll get some extras installed. The gallery should be next shortly, in a few weeks, I hope. Time to throw some images from the past few years at it, redo the whole gallery while I am at it and rescan some of the originals (that is going to take a considerable amount of time). Since so many friends and family members now have broadband too, the time is probably right to start serving bigger and heavier images instead of tiny ones which were tweaked for dial-up. Anyway. The gridserver blog is up and http://blog.icerabbit.com is forwarding here.  Update: Forwarding will be sorted out later. I ran into a little path loop between 1and1 and mt; so for the time being the blog subdomain is inactive.  

Continue reading >>