Vista Service Pack did not install. Times 2.

One of the two notebooks (dual core, vista home premium pre-installed) I use prompted that Vista SP1 was available as an automatic update. I figured why not, since this is the official release from 2 days ago. Speedy download. Installation goes pretty swiftly. Step 1, step 2 and step 3: 100%. Sweet. Reboot. And then this: Excuse me? It just did 100% on all three steps, taking its sweet little time overal, and then it says it couldn’t do it? So what exactly happened during all the installation steps? If it checks something that critical at the very end, how about doing that little hardware and software check (or whatever it is) at the very beginning of the update process? And, where can I trace the cause of the problem? I did not see any error information? Nor suggestions? Fortunately this botched update did not ruin the machine. Everything still looks the same and essential applications work. Small sigh of relief. And, now of course Vista SP1 is ready to be installed again. Funny. On a second Vista notebook the SP so far refuses to show up. Haven’t tried any other machines yet, but something tells me I will exercise some patience. There are plenty of similar stories on the web already too. Anyhow, you have to love Microsoft, right? Update: I am too curious what the failure rate will be so I am already trying it on another machine. This one is a year younger, pretty much ‘stock’ (or factory default) and faster. We’ll see. Update 2: Absolutely fabulous. 25 minutes into the installation. Step 2 is completed. System reboots. A blue screen of death. My system is unable to start. Windows Startup Repair can’t repair the problem. System restore … attempting … Update 3: Fortunately I landed back on my desktop after some very long 15 minutes. My conclusion, with two failures and especially after that Blue Screen Of Death, is that this Service Pack 1 for Vista is not ready for prime time. Two solid and fast machines, less than a year old, from mainstream manufacturers and neither can be updated? I recommend others to just wait. Maybe once you hear on the web from somebody who has the same machine and updated his/her’s fine; you can be confident it will work. To me it is not worth the 40 min hassle nor risking data and possibly having to reinstall the machine. I have read some reports where it took several hours to both install and revert SP1. I can’t imagine sitting through that worrying if the machine will boot.

Continue reading >>